Service Degradation - US - 10DLC & Campaign provisioning

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 21/08/2025 11:05 UTC
Incident End Time: 21/08/2025 17:30 UTC
Posted Aug 21, 2025 - 19:42 UTC

Monitoring

Dear Client,

TCR and nnSR have implemented fixes and we are monitoring the results.
Posted Aug 21, 2025 - 18:36 UTC

Identified

Dear Client,

We are currently experiencing issues affecting 10DLC Campaign and Campaign Number provisioning.
Our partners, TCR and nnSR, are experiencing outages and are actively working to resolve them.

Impact:
Customers may be unable to perform campaign provisioning or campaign number provisioning actions at this time.
Posted Aug 21, 2025 - 17:47 UTC
This incident affected: Campaigns (Campaigns (North America 🇺🇸 / 🇨🇦), Campaigns API (North America 🇺🇸 / 🇨🇦)).