Delivery Issue Dominican Republic - Claro
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2023-03-27 20:34 UTC
Incident End Time: 2023-03-27 23:42 UTC
Posted Mar 28, 2023 - 01:04 UTC
Investigating
We are currently observing delivery issues towards the Dominican Republic - Claro.

Incident Start Time: 2023-03-27 20:34 UTC

We will update as soon as we have more information.
Posted Mar 27, 2023 - 21:28 UTC
This incident affected: Connectivity by region (SMS - Latin America).