Delivery Issue Mexico - Telefonica MX
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2022-06-20 12:00 UTC
Incident End Time: 2022-06-21 14:00 UTC
Posted Jun 22, 2022 - 07:01 UTC
Investigating
We are currently observing delivery issues towards Mexico - Telefonica.

Incident Start Time: 2022-06-20 12:00 UTC

We will update as soon as we have more information.
Posted Jun 20, 2022 - 14:30 UTC
This incident affected: Sinch DI Services (SMS 365 Enterprise) and Connectivity by region (SMS - Latin America).