Delivery Issue Bhutan - TashiCell
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2022-05-16 05:56 UTC
Incident End Time: 2022-05-16 10:00 UTC
Posted May 16, 2022 - 12:26 UTC
Update
We are continuing to investigate this issue.
Posted May 16, 2022 - 06:45 UTC
Investigating
We are currently observing delivery issues towards Bhutan - TashiCell.

Incident Start Time: 2022-05-16 05:56 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted May 16, 2022 - 06:41 UTC
This incident affected: Connectivity by region (SMS - APAC) and Sinch DI Services (SMS 365 Enterprise).