Delivery Issue Australia - Telstra

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-11-07 08:42 UTC

Incident End Time: 2025-11-10 03:57 UTC
Posted Nov 10, 2025 - 04:21 UTC

Monitoring

We have been experiencing delivery issues towards Australia - Telstra.

A fix has been implemented and we are monitoring the results.

Incident Start Time: 2025-11-07 08:42 UTC

Impact: Delayed/Expired MT's, Late delivery receipts
Posted Nov 10, 2025 - 03:25 UTC
This incident affected: External Connectivity (SMS - APAC).