Sinch Dashboard

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident start time: 2025-04-16 at 15:14 UTC.
Incident end time: 2025-04-16 at 15:40 UTC.
Posted Apr 16, 2025 - 16:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 16:01 UTC

Investigating

Dear Client,

We are writing to inform you that we are experiencing intermittent outage for the Sinch dashboard.

Incident start time: 2025-04-16 at 15:14 UTC.

Our engineers are working to restore the service as soon as possible.

We apologize for any inconvenience this may have caused.
Posted Apr 16, 2025 - 15:49 UTC
This incident affected: Dashboard.sinch.com (Payment, SMS Administration, Numbers Administration, Analytics, Customer Support, 2FA, US Campaigns, Login/Sign up).