North American Long Number Provider
Incident Report for Sinch
Resolved
This is to inform you that the issue has now been resolved and we are able to see the DLR service successfully restored to normal levels.

Incident start time: 20:09 UTC 2020-02-12
Incident end time: 22:18 UTC 2020-02-12
Final resolution time: 00:03 UTC 2020-02-13
Posted Feb 12, 2020 - 23:15 UTC
Monitoring
Our North American Long Number Provider has implemented a resolution and is currently monitoring for stability.
Posted Feb 12, 2020 - 22:48 UTC
Identified
The cause of the DLR´s delays is now identified.
However, our provider is stilling working on it to resolved the issue.

Updates to follow.
Posted Feb 12, 2020 - 21:41 UTC
Update
We are writing to inform you that our North America Long Number Provider is experiencing an issue on their platform affecting delivery reports. The provider is working to resolve the issue as quickly as possible.
Posted Feb 12, 2020 - 20:43 UTC
Investigating
We are currently investigating delays impacting DLR.
Posted Feb 12, 2020 - 20:42 UTC
This incident affected: Connectivity by region (SMS - US - LongCode).