Delivery Issue Bhutan - TashiCell
Incident Report for Sinch
Resolved
Resolved - This incident has been resolved.

Incident Start Time: 2023-05-21 07:13 UTC
Incident End Time: 2023-05-21 13:10 UTC
Posted May 21, 2023 - 20:05 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2023 - 15:11 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2023 - 12:02 UTC
Investigating
We are currently observing delivery issues towards Bhutan - TashiCell.

Incident Start Time: 2023-05-21 07:13 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted May 21, 2023 - 10:42 UTC
This incident affected: Connectivity by region (SMS - APAC).