Sinch Operator Notification: Us and Canada Toll free number provider
Incident Report for Sinch
Resolved
This incident is confirmed as resolved at 2019-11-19 20:18 UTC
Posted Nov 19, 2019 - 21:08 UTC
Update
We are writing to inform you that our US and Canada Toll-free number provider is still experiencing issues on their platform, however, they have confirmed that the issue is now only affecting Delivery Reports.
MT and MO delivery were resolved at the time below.

Impairment incident Start Time: 2019-11-19 16:24 UTC
MT and MO delivery normalized: 2019-11-19 16:56 UTC
Impact MT: Clients may have experienced delayed toll free number MTs towards the US and Canada
Impact MO: Clients may have experience delayed toll free number MOs from the US and Canada

Impact DR: Clients may experience delayed delivery reports for toll free number MTs towards the US and Canada
Posted Nov 19, 2019 - 20:30 UTC
Identified
We are writing to inform you that our US and Canada Toll-free number provider is experiencing an issue on their platform. They are working to resolve the issue as quickly as possible.
Impairment Incident Start Time: 2019-11-19 16:24 UTC
Impact MT: Clients may experience delayed toll free number MTs towards the US and Canada
Impact MO: Clients may experience delayed toll free number MOs from the US and Canada
Posted Nov 19, 2019 - 16:34 UTC
This incident affected: Connectivity by region (SMS - CA - Toll Free, SMS - US - Toll Free).