Service Notification - Dashboard
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted Feb 12, 2021 - 19:02 UTC
Update
We are continuing to investigate this issue.
Posted Feb 12, 2021 - 14:43 UTC
Investigating
Dear Client,

We are writing to inform you that we are currently experiencing an issue processing payments on our Customer Portal, dashboard.sinch.com.

Our engineers are working to restore service as soon as possible.

We apologize for any inconvenience this may cause you and if you have any further questions or concerns please do not hesitate to reach out to support@sinch.com
Posted Feb 12, 2021 - 14:40 UTC
This incident affected: Customer Portal (Payment).