Service degradation - Customer dashboard

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-08-13 07:00 UTC
Incident End Time: 2025-08-21 16:30 UTC
Posted Aug 22, 2025 - 07:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2025 - 16:43 UTC

Update

The issue has been identified and our engineering teams are working on implementing a fix.
Posted Aug 21, 2025 - 13:59 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 21, 2025 - 13:06 UTC

Identified

We are currently experiencing issues impacting the Customer Dashboard.

Impact: Customers may not see concatenated message part references in Analytics or Message Search on dashboard.sinch.com.

We will provide ongoing updates on this page.
For any inquiries, please reach out to our support team at Support.sinch.com
Posted Aug 21, 2025 - 11:51 UTC
This incident affected: Dashboard.sinch.com (Analytics).