Incident start time: 2025-09-23 06:58 UTC Incident end time: 2025-09-23 16:10 UTC
Posted Sep 23, 2025 - 17:27 UTC
Update
All services have been restored. We are continuing to monitor for any further issues.
Posted Sep 23, 2025 - 16:33 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 23, 2025 - 16:22 UTC
Update
We are currently addressing residual issues related to the recent EST event. Our team is actively working on a full resolution. While progress has been made, services are not yet completely restored.
Posted Sep 23, 2025 - 15:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2025 - 15:34 UTC
Investigating
Sinch is currently investigating reports of call completion issues on the Elastic SIP Trunking Platform. Internal teams are actively engaged to resolve the issue. Updates will be provided as soon as possible.
We appreciate your patience and apologize for any inconvenience.
Posted Sep 23, 2025 - 14:37 UTC
This incident affected: Elastic SIP Trunking (Inbound Calling, Outbound Calling, International Calling, 9-1-1 / Emergency Services).