Sinch Contact Pro 23Q1 Release Date

Incident Report for Sinch

Resolved

This incident has been resolved.
Posted Mar 24, 2023 - 08:31 UTC

Identified

Release dates for Sinch Contact Pro 23Q1 have changed. New release dates are:

Release To Test (RTT) March 28, 2023
Release To Customer (RTC) April 15, 2023

All release dates for 2023 are listed in Release Schedule.
https://docs.cc.sinch.com/cloud/release-schedule/en/Release_schedule.pdf
Posted Feb 24, 2023 - 08:52 UTC
This incident affected: Contact Pro (Contact Pro - AF (South Africa), Contact Pro - AU (Australia), Contact Pro - EU (Europe), Contact Pro - NA (North America)).