Service Degradation - Customer Dashboard

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-10-30 14:14 UTC
Incident End Time: 2025-10-30 15:29 UTC
Posted Oct 30, 2025 - 16:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2025 - 15:45 UTC

Investigating

We are writing to inform you that we are currently facing a service degradation on the customer dashboard, Dashboard.sinch.com.

Impact: Analytics and Numbers Administration is degraded.

Our engineers are currently working on resolving this issue as soon as possible.
We will provide ongoing updates on this page.
Posted Oct 30, 2025 - 15:23 UTC
This incident affected: Dashboard.sinch.com (Numbers Administration, Analytics).