Sinch Engage - Inbox Degradation

Incident Report for Sinch

Resolved

This incident has been resolved.

Start Time (UTC): 2026-03-09 13:20 UTC
End Time (UTC): 2026-03-09 16:52 UTC
Posted Mar 09, 2026 - 16:58 UTC

Identified

We’re aware of an issue in our inbox at the moment, affecting new conversations, reopening a conversation or switching assignee by sending a message.

The issue has been identified and a fix is being implemented.

Start Time (UTC): 2026-03-09 13:20 UTC

We apologize for the inconvenience and appreciate your patience while we are working to resolve the issue.
Posted Mar 09, 2026 - 16:44 UTC
This incident affected: Sinch Engage (The Hub).