Sinch Engage - MT delivery issue

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-10-30 03:14 UTC
Incident End Time: 2025-10-31 00:37 UTC
Posted Oct 31, 2025 - 04:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 31, 2025 - 01:02 UTC

Investigating

We are writing to inform you that we are currently facing a service degradation on the Sinch Engage platform, causing a small subset of MT messages to fail.

Impact: A small subset of MT messages may fail to deliver.
Posted Oct 31, 2025 - 00:02 UTC
This incident affected: Sinch Engage (SMPP).