External Maintenance - United Kingdom 3 UK

Scheduled for Mar 17, 21:00 UTC  -  Mar 18, 05:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 10, 2026 - 13:10 UTC

Scheduled

United Kingdom 3 UK has scheduled a maintenance.
Impact: Clients may experience delayed or failed MT/MO traffic towards the United Kingdom 3 UK.

Maintenance start time: 2026-03-17 21.00 UTC
Maintenance end time: 2026-03-18 05.00 UTC
Posted Mar 18, 2026 - 13:09 UTC
This scheduled maintenance affects: External Connectivity (SMS - EMEA).