Delivery Issue Isle of Man - Manx Telecom
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2023-09-16 19:06 UTC
Incident End Time: 2023-09-17 05:43 UTC
Posted Sep 17, 2023 - 14:03 UTC
Update
We are continuing to investigate this issue.
Posted Sep 17, 2023 - 04:06 UTC
Update
We are continuing to investigate this issue.
Posted Sep 16, 2023 - 23:03 UTC
Update
We are continuing to investigate this issue.
Posted Sep 16, 2023 - 20:00 UTC
Investigating
We are observing delivery issues towards Manx Telecom - Isle of Man.

Incident Start Time: 2023-09-16 19:06 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Sep 16, 2023 - 19:50 UTC
This incident affected: Connectivity by region (SMS - EMEA).