Incident Notification – Sinch Contact Pro (EU)

Incident Report for Sinch

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 13:06 UTC

Investigating

We are currently investigating an issue affecting Sinch Contact Pro. Customers may experience service disruption or degraded performance.

Our operations team is actively working to identify the root cause.
Incident Start time: 08:00 UTC

Thank you for your patience.
Sinch Contact Pro Team
Posted Mar 10, 2026 - 12:02 UTC
This incident affected: Contact Pro (Contact Pro - EU (Europe)).