Service Notification - Dashboard
Incident Report for Sinch
Resolved
Dear Client,

This issue is now resolved.

Start time: 2020-09-17 UTC
Start time: 2020-09-18 05:15 UTC

Impact: Clients may have received an error when attempting to open and view the Billing-page.
Posted Sep 18, 2020 - 05:30 UTC
Investigating
Dear client,

We are writing to inform you that we are currently experiencing an issue with the "Billing"-page on our Customer portal, dashboard.sinch.com.

Start time: 2020-09-17

Impact: Clients may receive an error when attempting to open and view the Billing-page.

Our engineers are working to restore service as soon as possible. We apologise for any inconvenience caused.
Posted Sep 17, 2020 - 22:31 UTC
This incident affected: Customer Portal (Payment).