Sinch Elastic SIP Trunking - Call Completion Issues

Incident Report for Sinch

Resolved

All services are confirmed restored and this incident is now resolved.
Posted Jul 15, 2026 - 19:08 UTC

Monitoring

Elastic SIP Trunking service is now restored and we are monitoring. Services restored at approximately 15:10 UTC. We will continue to monitor and advise if any further issues are observed.
Posted Jul 15, 2026 - 15:31 UTC

Investigating

Sinch is currently investigating reports of call completion issues on the Elastic SIP Trunking Platform. Internal teams are actively engaged to resolve the issue. Updates will be provided as soon as possible.

We appreciate your patience and apologize for any inconvenience.
Posted Jul 15, 2026 - 15:00 UTC
This incident affected: Elastic SIP Trunking (API, Inbound Calling, Outbound Calling, International Calling, 9-1-1 / Emergency Services).