Delivery Issue Congo (DRC) - Africell

Incident Report for Sinch

Resolved

This incident has been resolved.

2025-05-09 02:17 UTC

2025-05-09 06:23 UTC
Posted May 09, 2025 - 07:03 UTC

Investigating

We are currently observing delivery issues towards Congo (DRC) - Africell

Incident Start Time: 2025-05-09 02:17 UTC
Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted May 09, 2025 - 04:31 UTC
This incident affected: External Connectivity (SMS - EMEA).