The Campaign Registry - Service Degradation
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted May 26, 2023 - 07:06 UTC
Identified
We are continuing to observe TCR service degradation, and are awaiting further updates from the carrier.

As soon as we have any updates, they will be shared accordingly.
Posted May 25, 2023 - 22:09 UTC
Update
We are continuing to investigate this issue.
Posted May 25, 2023 - 12:16 UTC
Update
We are continuing to investigate this issue.
Posted May 25, 2023 - 04:11 UTC
Update
We are continuing to observe issues towards the destination, and are awaiting further updates from the carrier.

As soon as we have any updates, they will be shared accordingly.
Posted May 25, 2023 - 00:06 UTC
Investigating
TCR (The Campaign Registry) is currently having an outage on their IRS Identity check functionality. This may result in the 10DLC registration process whereby Brands may not be able to be verified at this time.

Sinch will monitor and provide an update when possible.
Posted May 24, 2023 - 21:30 UTC
This incident affected: Provisioning API (Provisioning API Core) and Numbers API.