Service Degradation - Multiple Services - US Region

Incident Report for Sinch

Resolved

This incident has been resolved.

End time 20-10-2025 12:10 UTC
Posted Oct 20, 2025 - 12:28 UTC

Monitoring

We have observed degradations on multiple services including the Sinch Status page due to a degradation on our Hosting Provider.

Our Hosting Provider has confirmed the issue and are actively working on a resolution, at this time we are observing improvements for the affected services and we will continue monitoring.

Further updates will be provided as soon as we have more information to share.
Posted Oct 20, 2025 - 10:21 UTC
This incident affected: Voice (Data Calling, Phone Calling (PSTN), Video Calling, SIP Trunk), Verification (Flash Call Verification), Dashboard.sinch.com (SMS Administration, Numbers Administration, Analytics, Customer Support, US Campaigns, Login/Sign up), Conversation API (RCS, MMS), and Messaging APIs (REST - US, MMS - US, RCS - US).