Delivery Issue Mexico-Telefonica MX
Incident Report for Sinch
Resolved
This Incident has been resolved

Incident Start Time: 2024-03-15 15:56 UTC
Incident End Time: 2024-03-16 01:29 UTC
Posted Mar 16, 2024 - 01:30 UTC
Update
We are continuing to investigate this issue.
Posted Mar 15, 2024 - 23:08 UTC
Update
We are continuing to investigate this issue.
Posted Mar 15, 2024 - 20:24 UTC
Investigating
We are currently observing delivery issues towards Mexico-Telefonica MX.

Incident Start Time: 15-03-2024 15:56 UTC

Impact: Clients may observe delayed MT's/delayed MO's/Missing delivery receipts/Late delivery receipts towards the Telefonica Network-Mexico.

We will update as soon as we have more information.
Posted Mar 15, 2024 - 18:40 UTC
This incident affected: Connectivity by region (SMS - Latin America).