10DLC Brand Registration Issue
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident End time: 2022-12-05 14:30 UTC
Posted Dec 05, 2022 - 17:09 UTC
Investigating
We are currently experiencing delays in Brand Registration between The Campaign Registry(TCR) and T-Mobile

Incident Start Time: 2022-11-29 (TBD)

Impact: Delayed Brand Registration between The Campaign Registry(TCR) and T-Mobile

We will update as soon as we have more information.
Posted Dec 02, 2022 - 18:22 UTC
This incident affected: Connectivity by region (SMS - US - 10DLC).