Sinch Operator Notification: US and Canada Toll-Free number provider
Incident Report for Sinch
Resolved
We are writing to inform you that our US and Canada Toll-Free number provider has resolved their issue on the platform

Monitoring - DLR delivery has returned to normal time-frames.
Nov 22, 19:15 UTC
Resolved - This incident has been resolved.
Nov 22, 21:37
Posted Nov 22, 2019 - 22:39 UTC
Identified
We are writing to inform you that our US and Canada Toll-Free number provider is experiencing intermittent delays for delivery reports. MT and MO traffic is not impacted.
Incident Start Time: 2019-11-22 16:19 UTC.
Impact: Clients may observe delayed delivery reports for toll free number MTs towards the US and Canada.
Posted Nov 22, 2019 - 16:39 UTC
This incident affected: Connectivity by region (SMS - CA - Toll Free, SMS - US - Toll Free).