Delivery Issue Iraq - Asia Cell
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted May 15, 2023 - 15:01 UTC
Update
We are continuing to investigate this issue.
Posted May 15, 2023 - 05:47 UTC
Update
We are continuing to investigate this issue.
Posted May 15, 2023 - 00:02 UTC
Update
We are continuing to investigate this issue.
Posted May 14, 2023 - 21:05 UTC
Investigating
We are currently observing delivery issues towards Asia Cell Iraq.

Impact: Delayed/Failed MT/MOs, Missing/Late delivery receipts

We will update you as soon as we have more information.
Posted May 14, 2023 - 19:29 UTC
This incident affected: Connectivity by region (SMS - EMEA).