Delivery Issue Germany - O2
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2023-05-28 16:35 UTC
Incident End Time: 2023-05-28 20:37UTC
Posted May 28, 2023 - 22:02 UTC
Investigating
We are currently observing delivery issues towards Germany - O2

Incident Start Time: 2023-05-28 16:35 UTC
Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted May 28, 2023 - 17:53 UTC
This incident affected: Connectivity by region (SMS - EMEA).