Delivery issue Djibouti - Evatis

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-04-24 18:05 UTC

Incident End Time: 2025-04-24 20:39 UTC
Posted Apr 24, 2025 - 21:14 UTC

Investigating

We are currently observing delivery issues towards Djibouti - Evatis.

Incident Start Time: 2025-04-24 18:05 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Apr 24, 2025 - 19:39 UTC
This incident affected: External Connectivity (SMS - EMEA).