MMS Degradation - Canada, United States

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-10-22 19:30 UTC
Incident End Time: 2025-10-22 22:36 UTC
Posted Oct 22, 2025 - 23:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2025 - 22:54 UTC

Investigating

Dear Client,

We are writing to inform you that we are currently facing delays on our MMS platform.

Incident Start Time: 2025-10-22 19:30 UTC

Impact MMS: Delayed MTs/Delayed MOs/Missing delivery receipts/Late delivery receipts.

We appreciate your understanding, if you have any further questions or concerns please do not hesitate to reach out to support@sinch.com
Posted Oct 22, 2025 - 22:30 UTC
This incident affected: External Connectivity (MMS - US, MMS - US - Toll Free, MMS - US - 10DLC).