Dashboard MFA - Service Degradation - US
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 15:22 UTC
Update
We are still investigating this issue and will post an update as soon as we have new information.
Posted Mar 15, 2023 - 13:04 UTC
Update
We are continuing to investigate this issue.
Posted Mar 15, 2023 - 09:25 UTC
Investigating
We are currently observing an degradation with our 2FA service for dashboard.sinch.com.

Impact: US based clients may experience issues with receiving 2FA codes when logging in to dashboard.sinch.com.

We are working on resolving this issue and will provide further updates.
Posted Mar 15, 2023 - 07:46 UTC
This incident affected: Customer Portal (2FA, Login/Sign up).