Flashcall Service Disruption
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted about 2 years ago. Oct 12, 2017 - 13:55 GMT+00:00
Investigating
We are currently experiencing issues with our Flashcall verification service.

This is being investigated with a matter of urgency and we hope to have the issue resolved shortly.
Posted about 2 years ago. Oct 12, 2017 - 12:15 GMT+00:00