Customer Support - Ticketing System
Incident Report for Sinch
Resolved
This incident has been resolved.

No e-mails were lost during this incident, but a small number of customers may have experienced delayed responses from Sinch Support.
Posted Jun 29, 2022 - 22:46 UTC
Investigating
Dear Client,

We are currently experiencing issues with our ticketing system.

Impact: Responses or acknowledgments may not be received or get delayed.

We are investigating and will update you as soon there is more information available. If you have any further questions or concerns please do not hesitate to reach out to support@sinch.com
Posted Jun 29, 2022 - 21:29 UTC
This incident affected: Customer Portal (Customer Support).