Delivery Issue Brazil - SurfTelecom

Incident Report for Sinch

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 18:28 UTC

Investigating

We are currently observing delivery issues in Brazil - SurfTelecom

Incident Start Time: 2026-06-22 14:23 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
If you have any questions, please contact support@sinch.com.
Posted Jun 22, 2026 - 16:07 UTC
This incident affects: External Connectivity (SMS - LATAM).