Customer Support - Ticketing System

Incident Report for Sinch

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 18:06 UTC

Monitoring

A fix has been implemented and our ticketing system is restored to a pre-incident state.
Posted Aug 20, 2025 - 17:28 UTC

Update

We are continuing to investigate this issue.
Posted Aug 20, 2025 - 16:04 UTC

Update

We are continuing to investigate this issue.
Posted Aug 20, 2025 - 15:05 UTC

Investigating

We are currently experiencing an issue with our ticketing system related to the following emails:

support@sinch.com
apps.support@sinch.com
support-eu@sinch.com
supportindia@sinch.com

Customers may experience delayed responses from support.

As an alternative in the meantime, please raise all tickets via our ticketing portal at support.sinch.com.
Posted Aug 20, 2025 - 13:50 UTC
This incident affected: Dashboard.sinch.com (Customer Support).