Delivery Issue Singapore - Singtel
Incident Report for Sinch
Resolved
This incident has been resolved

Incident Start Time: 2023-05-30 03:40 UTC
Incident End Time: 2023-05-30 05:07 UTC
Posted May 30, 2023 - 06:21 UTC
Investigating
We are currently observing delivery issues towards Singapore - Singtel

Incident Start Time: 2023-05-30 03:40 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted May 30, 2023 - 04:06 UTC
This incident affected: Connectivity by region (SMS - APAC).