RTC Portal - Payment Issues
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted Jan 21, 2020 - 11:18 UTC
Identified
We are currently experiencing issues with PayPal transactions in our RTC portal (http://portal.sinch.com/)

This is being investigated and we are working to resolve the issue as soon as possible.

We are working with PayPal to resolve this issue.
Posted Jan 21, 2020 - 08:57 UTC
This incident affected: Customer Portal (Payment).