Service Degradation - Customer Dashboard
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident End Time: 2023-11-13 06:56 UTC
Posted Nov 13, 2023 - 12:08 UTC
Investigating
We are writing to inform you that we are currently facing a service degradation for sign-ins on the customer dashboard, dashboard.sinch.com.

Impact: Customers may be experiencing issues when trying to sign-in on dashboard.sinch.com.

We will update as soon as we have more information.
Posted Nov 13, 2023 - 06:48 UTC
This incident affected: Customer Portal (Login/Sign up).