Delivery Issue Mexico - Telefonica
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2024-06-27 18:34 UTC
Incident End Time: 2024-06-28 00:56 UTC
Posted Jun 28, 2024 - 02:02 UTC
Update
We are continuing to investigate the issue.
Posted Jun 27, 2024 - 20:36 UTC
Investigating
We are currently observing delivery issues in Mexico - Telefonica

Incident Start Time: 2024-06-27 18:34 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Jun 27, 2024 - 19:22 UTC
This incident affected: Connectivity by region (SMS - Latin America).