Delivery issue - North American Long number provider
Incident Report for Sinch
Resolved
We have been monitoring the traffic and no queued traffic is currently being observed.
We are marking this incident as resolved.

We appreciate your patience and apologize for any inconvenience experienced while we worked with the provider to resolve this issue.


Please contact support@sinch.com should you require further information or assistance.
Posted Mar 16, 2020 - 23:27 UTC
Monitoring
Our North American Long Number Provider has implemented a resolution and is currently monitoring for stability.
Posted Mar 16, 2020 - 13:35 UTC
Investigating
We are writing to inform you that our North America Long Number Provider is experiencing an issue on their platform.

Impact: Clients may experience delayed or rejected MT, MO and Delivery reports to/from US and Canada
Posted Mar 16, 2020 - 11:34 UTC
This incident affected: Connectivity by region (SMS - CA - LongCode, SMS - US - LongCode).