Delivery Issue Dominican Republic - Claro
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2025-01-23 23:02 UTC

Incident End Time: 2025-01-24 00:15 UTC
Posted Jan 24, 2025 - 01:08 UTC
Investigating
We are currently observing delivery issues in Dominican Republic - Claro.

Incident Start Time: 2025-01-23 23:02 UTC
Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Jan 23, 2025 - 23:52 UTC
This incident affected: Connectivity by region (SMS - Latin America).