Delivery Issue Germany - Lycamobile
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted Nov 11, 2023 - 12:59 UTC
Update
This issue has been resolved.
Incident Start Time: 2023-11-11 09:40 UTC
Incident End Time: 2023-11-11 12:28 UTC
Posted Nov 11, 2023 - 12:58 UTC
Investigating
We are currently observing delivery issues towards Germany - Lycamobile.

Incident Start Time: 2023-11-11 09:40 UTC
Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Nov 11, 2023 - 11:06 UTC
This incident affected: Connectivity by region (SMS - EMEA).