Service Outage - Sinch Engage Classic

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2026-04-01 09:36 UTC
Incident End Time: 2026-04-01 11:06 UTC
Posted Apr 01, 2026 - 11:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2026 - 11:14 UTC

Investigating

We are currently experiencing a complete outage of the Sinch Engage Classic system.

The service is not accessible at this time. Our teams are actively investigating the issue and working to restore functionality as quickly as possible.

We will provide further updates as more information becomes available.
Posted Apr 01, 2026 - 10:55 UTC
This incident affected: Sinch Engage (Sinch Engage (Legacy)).