Service degradation - SMS administration on customer dashboard

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start time: 05:20 UTC 2025-05-14
Incident End time: 08:25 UTC 2025-05-14
Posted May 22, 2025 - 08:32 UTC

Investigating

Dear Client,

We would like to inform you that we are currently experiencing a service degradation affecting SMS Administration within the customer dashboard.

Impact: You may encounter delays with SMS provisioning and pricing notifications.

Our engineering team is actively working to resolve the issue and restore full functionality as soon as possible.

We sincerely apologize for the inconvenience and appreciate your patience during this time.

For further information or assistance, please contact us at support@sinch.com.
Posted May 22, 2025 - 08:09 UTC
This incident affected: Dashboard.sinch.com (SMS Administration).