Delivery Report Degradation - USA & Canada
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2025-02-05 17:00 UTC
Incident End Time: 2025-02-05 19:30 UTC
Posted Feb 05, 2025 - 22:00 UTC
Investigating
We are currently observing delivery report issues towards the USA & Canada.

Incident Start Time: 2025-02-05 17:00 UTC

Impact: Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Feb 05, 2025 - 18:42 UTC
This incident affected: Connectivity by region (SMS - CA - LongCode, SMS - CA - ShortCode, SMS - CA - Toll Free, SMS - US - LongCode, SMS - US - ShortCode, SMS - US - Toll Free, SMS - US - 10DLC).