Delivery Issue Canada - ISP Telecom
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2024-07-15 19:23 UTC
Incident End Time: 2024-07-15 22:37 UTC
Posted Jul 15, 2024 - 22:45 UTC
Investigating
We are currently observing delivery issues in Canada - ISP Telecom.

Incident Start Time: 2024-07-15 19:23 UTC
Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Jul 15, 2024 - 20:27 UTC
This incident affected: Connectivity by region (SMS - CA - LongCode, SMS - CA - ShortCode, SMS - CA - Toll Free).