Delivery Issue - Kenya - Safaricom
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2023-05-28 06:23 UTC
Incident End Time: 2023-05-28 07:45 UTC
Posted May 28, 2023 - 09:13 UTC
Investigating
We are currently observing delivery issues towards - Kenya - Safaricom.

Incident Start Time: 2023-05-28 06:23 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts.

We will update as soon as we have more information.
Posted May 28, 2023 - 06:49 UTC
This incident affected: Connectivity by region (SMS - EMEA).