Platform Degradation - MMS US

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2026-05-07 23:53 UTC.
Incident End Time: 2026-05-12 19:20 UTC.
Posted May 12, 2026 - 19:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2026 - 19:00 UTC

Investigating

We are currently experiencing a platform degradation impacting MMS services in US

Impact: Customers may experience delays in MMS delivery.

We are actively investigating and will provide further updates as more information becomes available.
For any inquiries, please contact us at support@sinch.com.
Posted May 12, 2026 - 18:19 UTC
This incident affected: External Connectivity (MMS - US, MMS - US - Toll Free, MMS - US - 10DLC).