Delivery Issue Kenya - Safaricom
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2023-03-27 05:14 UTC
Incident End Time: 2023-03-27 13:40 UTC
Posted Mar 27, 2023 - 15:24 UTC
Update
We are continuing to investigate this issue.
Posted Mar 27, 2023 - 12:07 UTC
Update
We are continuing to investigate this issue.
Posted Mar 27, 2023 - 08:48 UTC
Investigating
We are currently observing delivery issues towards Kenya - Safaricom.

Incident Start Time: 2023-03-27 05:14 UTC
Impact: Delayed MT's, Delayed MO's, Missing delivery receipts, Late delivery receipts.

We will update as soon as we have more information.
Posted Mar 27, 2023 - 06:30 UTC
This incident affected: Connectivity by region (SMS - APAC, SMS - EMEA) and Verification (SMS Verification).